SlapOS is moving to Buildout 2

This blog post provides information on how to upgrade your Webrunner with the upcoming move to Buildout 2 on December 9th. These steps are required to not break your instances.
  • Last Update:2016-11-09
  • Version:001
  • Language:en

Upgrade Notice

Thanks to the help of all contributors SlapOS is finally ready to move to Buildout 2. You can find more information here:

Please note, that on Friday, December, 9th, we are upgrading zc.buildout to 2.5.2+slapos005 or newest versions for ALL software releases (including ERP5). A few software release might get upgraded before this date (the ones related to VIFIB Services).

Required Steps for Upgrade

Quick Steps

Your instance WILL GET BROKEN after 9/12/2016, if you are running your software on a computer or webrunner with buildout1, and you upgrade (or setup) your instance from latest slapos.git. It is therefore mandatory to upgrade packages and upgrade your webrunner to the latest version BEFORE the actual upgrade.

Rationale

Buildout2 can deploy Buildout1 inside, however it does not work the other way around, so Buildout1 CANNOT deploy Buildout2. So if you git pull and recompile your software before upgrading your webrunner, you are going to run into problems.

In order to prevent any issues during the transition, the VIFIB Team already released new packages for SlapOS with Buildout2 (already deployed on most of all computers). All erp5testnodes are already upgraded to use the buildout2 and a new version of webrunner (1.0.41) is available for upgrades (or new instances).

It is always possible for the projects to "pin" the versions of zc.buildout to 1.7.1.post14 on your projects or change extends to use a frozen version (what some projects already do).

Upgrading/Downgrading zc.buildout

In order to upgrade your software release before the 9/12/2016, you can remove buildout-versions from extensions:

[buildout]
extensions -= buildout-versions

and increase the versions of zc.buildout and zc.recipe.egg:

[versions]
zc.buildout = 2.5.2+slapos005
zc.recipe.egg = 2.0.3+slapos002

In order to Downgrade, you can include on your software release:

extensions += buildout-versions
[versions]
zc.buildout = 1.7.1.post14
zc.recipe.egg = 1.3.2.post5

Do not hesitate to ask question on the Forum.

Contact

  • Photo Rafael Monnerat
  • Logo Nexedi
  • Rafael Monnerat
  • rafael (at) nexedi (dot) com
  • 2
  • Photo Sven Franck
  • Logo Nexedi
  • Sven Franck
  • sven (dot) franck (at) nexedi (dot) com